Sunday. 01 Aug 2021

Pada postingan kali ini saya akan membagikan cara untuk mengatasi error  di Android Studio : Default interface methods are only supported starting with Android N…..

Bila anda sedang melakukan upgrade Android Studio ke versi terbaru atau menambahkan library baru lalu pada saat running aplikasi android ternyata muncul error tersebut anda bisa coba lakukan cara berikut yaitu dengan menambahkan sourceCompatibility JavaVersion.VERSION_1_8 dan targetCompatibility JavaVersion.VERSION_1_8 pada module build.gradle, langkah-langkahnya seperti berikut yaitu:

Buka file module build.gradle:

Lalu tambahkan

compileOptions {
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}
Pada sub Android:
 Setelah itu silahkan coba running aplikasi android kembali, hasilnya proses build graddle sukses: